В WinRAR исправили уязвимость, существовавшую 19 лет

Специалисты компании Check Point сообщили о критической уязвимости в популярном архиваторе для Windows, позволяющей выполнить код на целевой системе. Для успешной атаки злоумышленнику потребуется заставить пользователя распаковать вредоносный архив.

Уязвимость обхода каталога затрагивает все версии WinRAR, выпущенные за последние 19 лет. Проблема кроется в устаревшей сторонней библиотеке UNACEV2.DLL, используемой архиватором для распаковки файлов в формате ACE. Поскольку WinRAR распознает формат по содержимому файла, а не его расширению, атакующим потребуется всего лишь изменить расширение .ace на .rar, чтобы замаскировать вредоносный архив.

Эта уязвимость предоставляет возможность извлечь файлы из архива в нужную злоумышленникам папку, а не назначенную пользователем. Таким образом они могут поместить вредоносный код в папку автозагрузки Windows, который будет автоматически выполняться при каждой загрузке системы.

В конце января нынешнего года разработчики WinRAR выпустили версию WinRAR 5.70 Beta 1, устраняющую уязвимость.
Всем пользователям рекомендуется обновиться до новой версии.